Jump to content
DeployCentral

Unable to download Platform Pack


fllorente
 Share

Recommended Posts

Hi, Support!

I'm trying to download the Platform Packs I need, but they are not being downloaded. 

I can browse the available Platform Packs without any problem, then I click on [Download] and I get a popup saying "The Platform Pack is now being downloaded and can be accessed in Platform Pack Library. Download another Platform Pack or click 'Close' to exit.", but when I go to the Platform Pack Library it is listed with a size of 0 B and if I try to open it I get the error "Unable to open the PlatformPack. The Platform Pack may be corrupt." If I browse to the Platform Pack folder 'C:\SmartDeploy\Platform Packs' the .ppk file is there, but it's 0 KB in size and opening it with the NotePad I can see it's just an empty file. 

I've reviewed the logs in 'C:\SmartDeploy\Logs', but I see no errors there apart from the ones reported above. The computer is a newly installed Virtual Machine with Windows Server 2012 R12, I've installed the "Desktop Experience" feature and I've also added 'https://*.smartdeploy.com/' to the Trusted Sites list in the Internet Explorer security configuration. I've also completely disabled the antivirus (Sophos Endpoint Security and Control 1.3), which, by the way, shows no incidents related to this issue. All tests so far have been unsuccessful. I've tried with the two latest versions of Smart Deploy, 2.0.2020 and 2.0.2030, the behaviour is the same on both.

Well, back in the times when we could still use the web interface to download the Platform Packs this would have been just a minor nuisance... but now this is a serious and blocking issue, as we just cannot download any Platform Pack on this computer.

That's all. If you need further information don't hesitate on asking. Any suggestion will be greatly appreciated. 

Thanks in advance and best regards,
-- Javier Llorente

Link to comment
Share on other sites

Hi Javier,

Here are the recommended steps in order to get the SmartDeploy console working with your firewall and prevent any issues download platform packs via the console.

· Disable any anti-virus on the SmartDeploy host

· The console uses standard HTTP and HTTPS ports to initiate the download – you’ll need to make sure that SmartDeploy Enterprise can access ports 80 and 443.

· You may need to create an exception in your firewall for this executable: C:\Program Files (x86)\SmartDeploy\SmartDeploy Enterprise\Resources\ConsoleService.exe

· Allow download.smartdeploy.com/* through your firewall

Beyond that, there may be application-specific rules that are restricting traffic on your network – it’s possible that only browsers are permitted to download files, for instance.

If you still have issues, let us know,

Thanks,

SmartDeploy Support

Link to comment
Share on other sites

Hi Support,

First of all, thanks for the prompt answer. :-)

- AntiVirus is uninstalled
- Firewall is disabled
- Console is accessing HTTP/HTTPS ports

I've checked the network usage and I've found that the ConsoleService.exe process is trying to connect to the old corporate proxy... which may be what is causing this issue. But the use of a proxy server is disabled on that computer, it should go out to the Internet directly. In fact, HTTP/HTTPS traffic from web browsers is going out directly.

Looks like I'm having the same issue as user @CTEK described in this thread: 

Any ideas?

Thanks in advance and best regards,
-- Javier Llorente

Link to comment
Share on other sites

  • 2 weeks later...

Hi, @SmartDeploySupport

We have found the root cause of this issue. Apparently, even though the network configuration is set to access the Internet directly, the internal component that downloads the Platform Packs is still trying to use the automatic configuration and accessing the WPAD server to do so. That explains why the SmartDeploy console was working correctly but the Platform Packs were not being downloaded. Once we have specifically set an exception in the WPAD for the Deployment workstation, we have been able to download the Platform Packs without further problems.

For us, this is clearly a bug: the component that downloads the Platform Packs should be using the same configuration as the whole console. Please review it so this unusual behaviour may be fixed in next versions.

Best regards,
-- Javier Llorente

Link to comment
Share on other sites

  • 8 months later...

I'm having the same issue....it would sometimes download and sometimes get stuck, really random.  Can you explain how you "specifically set an exception in the WPAD"?  Haven't had much luck with months of email threads from their support, just the runabout with firewall, ports and check your network administrators, etc.  Thanks!

Link to comment
Share on other sites

Hi, @ngoa

The Web Proxy Auto-Discovery (WPAD) file just tells the computer when to use the proxy server and when to connect directly to the internet. In my case, the WPAD file was set to use the proxy even though my workstation was manually set to use direct connection instead of using the automatic configuration (which is defined by the WPAD file). Once the network team at my company fixed the WPAD file by setting it to allow my workstation to direct connect to the Internet, the download issue was over.

I hope this will be of help. :-)

Best regards,
-- Javier Llorente

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...