Jump to content

Error starting service during SmartDeploy Enterprise installation

Recommended Posts

Hello everyone. I am new to the DeployCentral Forum.

I am attempting to install a trial version of SmartDeploy Enterprise and get error "Error 1920. Service SmartDeploy Enterprise Console Service (SDEConsoleService) failed to start. Verify that you have sufficient privileges to start system services".

I've tried running the install with my user id (I do have admin rights), logged on as administrator and used the option to run executable as administrator, and still get the same error message.

Any ideas? Any info will be greatly appreciated.

Link to comment
Share on other sites

Glad to see i am not the only one having the same issue.. Did you ever have any luck with this? Nothing I have tried has worked.

Any other ideas?

Things I have tried:

Disabling antivirus, firewall, windows defender, ect

Installing through a different profile

Reinstalling old product and then uninstalling before upgrading (wiping all leftover enteries).

deleting the service (sc delete)

"run as administrator" install

calling the installer rude names


Windows 7 pro x64

Version 2.0.1010

Link to comment
Share on other sites

Hi all,

Can you run the following command from the command prompt and e-mail the C:\SmartDeploy.log to support@smartdeploy.com

SDESetup.exe /V" /lv C:\SmartDeploy.log"

Also, if you're on a domain, dis-join and see your results as well as it may be related to a group policy of some sort.


SmartDeploy Support

Link to comment
Share on other sites

Just an fyi- ended up just starting from scratch with a new build. Just had too many variables on my machine (ie installed programs) to make sifting through each potential source of the issue worth it.

However for anyone else that is having trouble I recommend looking into the version of Sql CE installed, your version of .net and any versions of the windows provisioning tools installed as the issue might have been there.

Link to comment
Share on other sites

  • 6 years later...

PPhil01... Good call on missing pre-requisite - successfully installed after addressing missing pre-req.  

Installing the missing prerequisite solved the problem for me!

Pre-Requisites for version 3.0.1020 are:

Microsoft ASP.NET Core 3.1.19 - Shared Framework (x64)
Checksum (SHA512):


Microsoft ASP.NET Core 3.1.19 - Shared Framework (x86)
Checksum (SHA512):


Microsoft Windows Desktop Runtime - 3.1.19 (x64)
Checksum (SHA512)


Microsoft Windows Desktop Runtime - 3.1.19 (x86)
Checksum (SHA512)


Windows Assessment and Deployment Kit - Windows 10
Checksum (SHA512)


Windows Assessment and Deployment Kit Windows Preinstallation Environment Add-ons - Windows 10
Checksum (SHA512)


MongoDB 4.2.10
Checksum (SHA256)



Link to comment
Share on other sites

  • 5 months later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...