Jump to content

Windows 11 22H2 Deployment Getting Stuck at "Getting Ready"


Recommended Posts


I am currently working on our company's upgrade to Windows 11 from Windows 10 with a brand-new image. There is one program that requires the image be put on our domain to be installed correctly. Adding the image to the domain and then putting it back to workgroup before capturing it is causing the deployment to fail at the post sysprep "Getting Ready" stage. It sits there endlessly and never fails. I left a laptop sitting at this stage for over 48 hours to see if anything would eventually happen. If I manually reboot the installer, it says "The computer restarted unexpectedly or encountered an unexpected error. Windows installation cannot proceed. To install Windows, click "OK" to restart the computer, and then restart the installation". I am attempting to deploy the image with both ISO and Push methods.

If I leave the image with all other steps done to it except adding to the domain, it works as expected and deploys to multiple systems and VMs. I have narrowed down the failure to adding the image to the domain. The default OU it is being added to does not apply any group policy. This process has also worked successfully on Windows 10.


What steps should I take to further investigate this issue, or where can I attempt to gather logs for this issue?

Link to comment
Share on other sites

Link to comment
Share on other sites


What I would recommend is deploying your software as a post image task, or Application Pack. That way you don't have to join the domain on your virtual reference machine. The application would install after the domain join during deployment.

You won't want to join the domain on the virtual machine because it can cause issues like you're experiencing. If you want to see the deployment logs, boot the target machine from your SmartDeploy boot media. Select Collect Logs and save the zip to a USB or network location.



SmartDeploy Support

Link to comment
Share on other sites

  • 1 month later...

Hi NoIaITGuy

Yeah, this issue was resolved by following Devon's reply. Removing software installed on the image itself. Then using App packs and Answer File tasks instead.

If this doesn't work. Then submitting the deployment logs to support@smartdeploy.com to have the Smartdeploy Support team review, and hopefully find out if something else is going on.

Thank you,

Petar Nikolov

Smartdeploy Support

Link to comment
Share on other sites

3 hours ago, NolaITGuy said:


Did you ever resolve this? We are having the exact same thing happen in our environment, and we're starting to pull our hair out over this.



I posted the solution above but forgot to quote you.


Making those changes didn't seem to cause any issues but it's still a bit sketchy having to change the sysprep configuration files for it to work properly.

Link to comment
Share on other sites

  • 2 weeks later...
On 12/27/2022 at 8:59 AM, TRogers said:

Ended up getting it figured out. The problem is a sysprep bug on W11 22H2 only. It works fine on W11 22H1. The lines in the file "C:\Windows\System32\Sysprep\ActionFiles\Specialize.xml" with "Capisp.dll" need to be removed for it to image properly. 

How did you even find this?

Link to comment
Share on other sites

  • 4 weeks later...

I was trying to get more info about this also and found this discussion.
Windows 11 sysprep - Microsoft Q&A

Looks like it has to do with CryptoSysPrep_Specialize.

Some users have said they re-created the image and it worked as long as you do not join it to the domain.  Still looking for options to fix it without having to rebuild, but I may just rebuild it anyway just to clean up any misc. files left behind from previous installs.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...