Jump to content

Application Pack Deployment - Stuck on ExecuringTasks status


Recommended Posts

SmartDeploy 3.0.

I have an issue when deploying an application to a Win 10 computer where the status is stuck on "ExecutingTasks".  The installation does not finish and the status never changes. 

I deleted the SD folder within C:\Windows\Temp but this does not reset the computer status in the Console.  If I restart the smartdeploy client service on the computer the same application pack is again copied to the SD folder within C:\Windows\temp.  I’ve also tried restarting the smartdeploy api service on the smartdeploy server with no luck. 

 The option to cancel the Pending is grayed out in the Smartdeploy console for that task.  I've also tried uninstalling/reinstalling the smartdeploy client without success.

How do I terminate/end/cancel the application deployment?  

Link to comment
Share on other sites

  • 2 months later...

I had this same issue when forgot to include the "/c" in the arguments of my last "Run Command" task post-deployment. No matter what I did (reboot console, reboot client, restart services on both ends, power down client and wait, etc.), nothing canceled the "ExecutingTasks" message until I deleted the computer from AD, re-joined it to the domain and rebooted; which probably wasn't even the fix since it's also possible that the task finally timed out. 
 

Link to comment
Share on other sites

10 hours ago, Jason M said:

I had this same issue when forgot to include the "/c" in the arguments of my last "Run Command" task post-deployment.

Confirmed this was the cause in my scenario, as I forgot to include "/c" in yet another "Run Command" task. The fix was to kill all the hung CMD processes running on the client machine. 

Link to comment
Share on other sites

You will also want to make sure to delete all files/folders in C:\Windows\Temp\ on the client machine. If files get stuck in there it can cause issues with future deployments.

Specifically if there is a folder called SD in C:\Windows\Temp, delete that. 

 

Thanks,

Devon

SmartDeploy Support

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...