Jump to content
DeployCentral

Regional settings lost


ilmara
 Share

Recommended Posts

Hello,

SmartDeploy is completly ignoring any regional settings I set. The default user config of the reference VM, the keyboard layout and regional settings are all reset to en-US.

I've tried to set it in the answer file but there is no granularity and the parameter is completly ignored. I've tried to manually edit the answer file with your blog post information :

<regional_settings skip="0">
  <time_zone>(GMT+01:00) Brussels, Copenhagen, Madrid, Paris</time_zone>
  <input_locale>
    <ui_language>en-US</ui_language>
    <system_locale>fr-FR</system_locale>
    <user_locale>fr-FR</user_locale>
    <input_locale>fr-FR</input_locale>
  </input_locale>
</regional_settings>

But that gets ignored as well (the timezone is set but the rest is discarded).

I've tried to use a task to import a reg file in HKEY_USERS/.DEFAULT but it seems to be overwritten.

I'm deploying using WDS. How can I specify my regional settings?

Link to comment
Share on other sites

Hello,

I started the trial with build 2060 and saw a fix related to languages in build 2080 so I upgraded, recaptured the image and recreated the WDS boot image and I still have the same issue.

Here are the relevant tasks I run:

<task>
  <phase>FIRSTBOOT</phase>
  <command>C:\Windows\System32\lpksetup.exe /i fr-FR en-GB en-US /r /s /p C:\Template\LP</command>
</task>
<task>
  <phase>FIRSTBOOT</phase>
  <command>C:\Windows\System32\reg.exe import C:\Template\International.reg</command>
</task>
<task>
  <phase>FIRSTBOOT</phase>
  <command>C:\Windows\System32\reg.exe import C:\Template\Keyboard.reg</command>
</task>

I copied the language packs in C:\Template\LP and the 2 registry files are attached to this post. I'm not sure if this is relevant, but the unattend.xml file in C:\Windows\Panther is showing en-US as the InputLocale, SystemLocale, UILanguage and UserLocale.

International.reg

Keyboard.reg

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...