Jump to content
DeployCentral

UEFI deployment


AP608
 Share

Recommended Posts

I will be upgrading 30 users in the spring of 2017. The deployment will be to EFI enable PC. From what I understand EFI image capture is not supported by SmartDeploy. I was inform that SmartDeploy can be deploy to a EFI ready pc with a standard Bios image. My question is, Has anyone done this? If you have can your share some information on how this is done? Since there are multiple partitions that will need to be created EFI, MSR, Primary, recovery partitions for EFI enable PC's to work. Do I have to create the EFI needed partitions before hand or stop my deployment and create the partitions and start it again? If this can be automated it would be even better. 

I am going to keep working on this and will share my findings.  

Link to comment
Share on other sites

Hello,

You're correct - a BIOS-based VM can be captured and deployed onto a UEFI-based physical device without issue. Matching the boot method from the reference VM to the target device is neither necessary, nor supported. You don't need to manually create any partitions - Windows will automatically create any partitions that are needed at deployment time. The process is identical to how you've been creating images so far - create a new, blank VM, install Windows from OS media, install software, shut the VM down gracefully, and capture to a .wim file using Capture Wizard. You would then run Media Wizard to create SmartDeploy media (by default, all SmartDeploy media is UEFI-compatible unless you specifically select otherwise in Media Wizard), then select the captured image (.wim), which will be applied to your target device.

The only thing you might want to watch out for is if you're deploying Windows 7 to UEFI-based target devices, you may need to modify the BIOS settings to ensure that the device will boot properly. If you have any issues after applying a Windows 7 image to a UEFI-based device, go ahead and shoot us an email at support (at) smartdeploy.com, making sure to note which make/model of device you're deploying to. We can then advise whether any BIOS settings changes may be needed.

SmartDeploy Support Team

 

TECH RESOURCES

SmartDeploy User Guides

DeployCentral Forum

Platform Pack RSS

 

SOCIAL

SpiceworksTwitterfacebookyoutube



 

Link to comment
Share on other sites

You have to select the CD/DVD option when creating WDS boot media. This will create both a boot .WIM and an ISO. These steps are on page 6 in our WDS documentation:

https://www.smartdeploy.com/wp-content/uploads/SmartDeploy_WDS.pdf

Thanks,

SmartDeploy Support

Link to comment
Share on other sites

I am getting the following two error when deploying to the HP 1040 G1 with UEFI enabled. The two error are, Fail to provision one or more disk and an exception has occurred. I am able to deploy to the same pc in legacy mode but get the above errors when deploying in UEFI. I check the drive with diskpart and the following partitions were created, Recovery, System, Reserved, and Primary. Is there a link to a video or instructions on deploying to UEFI ready PC? 

Link to comment
Share on other sites

Once you receive that error, dismiss it and close out of the Deploy Wizard so you're returned to the splash screen. Click the link to open a command prompt and browse to X:\Windows\Temp\deploy.log and save it to a USB/Network share. Send support @ smartdeploy .com your deploy.log. 

Thanks,

SmartDeploy Support

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...