Jump to content

"failed to provision one or more disks" followed by "an exception has occurred"


Recommended Posts

Hello, we have a tablet computer with integrated SSD Drive, model is Motion F5m.

When I deploy Windows 7 32bit to the machine it works just fine. 

When deploying Windows 10 64bit to the machine it presents an error message: "failed to provision one or more disks" followed by "an exception has occurred".

Before it was happening about half-way through the second partition copy, now it happens almost immediately when starting the second partition.


This occurs during the provisioning phase where it formats the drives, installs the boot loader and copies the WIM... pre-first boot and sysprep and all that.

I used the USB Drive with WIM + PPK.. the same USB drive to deploy 3 computers with no issue. This 4th computer it just doesn't work anymore... same Make / Model / Specs everything.


So following usual logic I have:

1) Ensured Win10 64bit was activated, and all windows updates applied.

2) Ensured Windows 10 was shutdown clean "shutdown -s -t 0"

3) Re-Captured the WIM

4) Used Diskpart to wipe the USB Stick -> clean, format quick fs=ntfs and all that

5) Recreated the Boot Media using 64bit NTFS, Legacy Boot

6) Still can't get this to work with the same error messages presented above


Other things I have tried:

1) Reset BIOS to default values

2) Tried to load from Device USB Port instead of the docking station USB 2.0 port

3) Tried to load from the docking station USB 2.0 port

4) Tried a different make/model of USB stick


Wondering if anyone can point me to some better log files, or has experienced this issue before? I can't find anything by searching the forums or google....

Please help I've spent 3 days on this so far, thanks!


Additional Info:

SmartDeploy Enterprise 2.0.1060, activated.

Win7 setup is 32bit, Boot USB is 32bit Legacy Boot.
Win10 setup is 64bit, Boot USB is 64bit Legacy Boot.

Maybe the 64bit area is the problem???

Link to comment
Share on other sites


Once you receive the error, dismiss it and close out of the Deploy Wizard so you're returned to the SmartDeploy splash screen. Click the link to open a command prompt and browse to the following log and save it to a USB/Network share:


Send deploy.log to support @ smartdeploy .com and we can take a look what may be going on.


SmartDeploy Support

Link to comment
Share on other sites

Hi There, so we can mark this one solved! The issue was the following:


1) The WinPE 64bit environment had a problem. As soon as it would start to provision the disks it would fail with the message "failed to provision one or more disks" followed by "an exception has occurred".
Using diskpart it would always fail on the "format quick fs=ntfs" command, the solution to this problem was to add the Sata AHCI Drivers to the PPK for the Windows PE 5.1 x64 environment.
So the x64 environment was the problem in this case.. drivers fixed it.

2) The second issue was that my VM Partition was 120GB size, but the SSD Drive in the computer was only 119MB. Rookie mistake... but it fails with the same error message "failed to provision one or more disks" followed by "an exception has occurred". 
So I booted the VM, used Computer Manager -> Disk Manager and shrunk the partition. Re-Captured the WIM. Problem Solved.


The very interesting part is the USB Drive with WIM + PPK worked on 3 computers, and failed on the 4th.. I can only assume there is some difference in the Chipset and/or SSD Drive with this one computer.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...