Jump to content

Lenovo P700 vs. Smart Deploy vs. RAID - Can't find boot disk


Recommended Posts

I'm testing Smart Deploy against a Lenovo P700. I use a WDS server to deploy images.

I use Smart Deploy in a production environment against several Lenovo models. P500's, W541's, W700's, S20's, S30's, T520's, T530's... you get the point. All work great.

This P700 has a built in LSI RAID card that the Hard Drives plug into. The Smart Deploy wizard sees the Hard Drive at the beginning stage of deploying the image, sends the image to the Hard Drive, and then applies the Platform Pack.

But after that first stage, when the PC reboots to first Start Windows and detect hardware and drivers, it says it there is no bootable device.

I can immediately switch the hard drive to be connected to the SATA port and it will boot and begin the hardware discovery and the rest of the Smart Deploy process as usual.

I have tried configuring the RAID and seeing if there are any settings that would affect this but nothing jumps out at me. It's configured as the BOOT device in the RAID config and it's a JBOD.

Any advice? Is the RAID an issue with Smart Deploy?

Link to comment
Share on other sites

Hi Scott,

RAID is not generally an issue with SmartDeploy - although I doubt we've tested much with JBOD, since there's so much variability in that configuration. Can you elaborate on how the disks are configured? (i.e. how many physical disks configured as how many volumes)?

You mentioned that you "can immediately switch the hard drive to be connected to the SATA port and it will boot" - how was it connected before you made this switch? Are you referring to just one of the hard drives in the JBOD configuration (suggesting that SmartDeploy did not see the RAID configuration, and instead deployed to the first physical disk)?

SmartDeploy Support Team


SmartDeploy User Guides

DeployCentral Forum

Platform Pack RSS


Link to comment
Share on other sites

The P700 is similar to the P500 in that the Hard Drives are located in carriages at the bottom of the case. Behind the carriages, on the motherboard, are built-in data/power connectors for any size or type of hard drive that would sit in the carriage. As most I.T. folks know, SSD drives will position themselves differently vs. the traditional hard drive.

I only have a single, 500 GB, SSD drive in the chassis. In the RAID configuration utility (from inside the computers BIOS), you can configure the disk as a JBOD or choose "Make Configured Good" (which I believe you would use if you were using RAID 1 and needed to make a Hot Spare).

Whichever one I choose, I can image to the drive but it will never boot to the drive when the PC comes around for that to first occur. I'm not seeing anything in the RAID utility to make partitions or anything, just the disk configuration.

I can immediately take the disk out of the carriage and have it go into a normal SATA port and it will boot right up and take off.... so Smart Deploy is seeing the disk, imaging to the disk, but somehow; the drivers for the RAID controller are not put into the image to make it bootable through the RAID controller.

I concede that there may be more settings in the RAID controller that I may need to mess with but I can say that I've made a couple passes at it and nothing jumps out at me as something that would affect boot up like this.

Link to comment
Share on other sites

Well, I essentially am by not configuring anything... i.e. Choosing to make the disk "Make Known Good" or "JBOD".

The state of the disk is either/or when connected to the RAID controller. I'm not trying to configure RAID 0 or RAID anything... I tried to use settings that essentially just take it as blank/stock/no config and I get the same result.

Very strange.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...