Jump to content
DeployCentral

Deploying image to machine with multiple hard disks


Recommended Posts

To start, I've had a very easy time building and deploying images with SmartDeploy...until I tried to deploy my images to a Dell Precision M3800 with dual hard drives.

The problem is, the SSD (where the image should be applied) is identified as Disk 1, and the SATA drive is Disk 0. I can't get this to deploy to anything other than Disk 0 however. Removing the SATA drive as workaround is not a viable solution for me. I tried offlining the disk in diskpart, and precreating a partition on the SSD and assigining volume letter C, but SmartDeploy errors out when trying to apply the image. Wipe and Load drives option does not work either. Is there not a command line\script method where I can select the physical disk to apply the image?

Any help here is appreciated!

Link to comment
Share on other sites

Hi Adam,

I'm afraid the targeting of Disk 0 is an architectural feature - it can't be changed through any mechanism currently available in SmartDeploy.

Creating separate partitions is not be a viable workaround - that would just deploy two partitions to Disk 0.

I see you've mentioned changing the physical configuration of the disks as a possibility - is it possible to swap the position of the two drives? The assignment of Disk 0 is dictated by which port on the system board that the drive is plugged into. Assuming the drives are identical form-factor and in interchangeable slots, you can try swapping their positions, and see if it targets the SSD instead.

If you want to deploy data to both drives, you can capture a VM that has multiple virtual hard disks attached (via a warm/online capture) - but the primary drive targeted would still be Disk 0, so the same underlying issue would need to be resolved first.

Feel free to email us at support@smartdeploy.com if you have any further questions.

SmartDeploy Support Team

TECH RESOURCES

SmartDeploy User Guides

DeployCentral Forum

Platform Pack RSS

SOCIAL

Link to comment
Share on other sites

Unfortunately the disks are not installed in idenctical slots. The SSD is in an mSATA. I believe I've read somewhere that you can physically disconnect the drive that's recognized as disk 0, and have BIOS reassign the disk id's to the remaining drives. But I am not sure about the validity of that workaround, and was hoping to avoid this. Thanks for the quick response.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...