Jump to content
DeployCentral

Which VNS use ?


dmarandola
 Share

Recommended Posts

Dear SmartDeployers,

I am testing the deployment of Windows 7 with SmartDeploy. Actually I think it's a really great tool, automating all this tasks that I was manually doing before, I totally love it!

I tried yesterday to build a SmartPE CD with VNC Server included. Then I started with it and downloaded VNC Viewer from http://www.realvnc.com/download/viewer/ (the latest version for Windows 7 x64), but I was unable to connect due to a problem with a DPM plugin, or something else (that was actually the error message). So I was wondering which version or VNC viewer you were using? RealVNC? TinyVNC? Another one ?

Thanks in advance for your precious help.

Link to comment
Share on other sites

The VNC Server allows for VNC access to a machine that is booted to the SmartDeploy Boot Environment (SmartPE). Typically we have users use Cloud Services to initiate the VNC connection, for more information about Cloud Services you can check out this doc. You could also use your own VNC Client to connect, however there are some gotchas with that:

If you want to connect to the VNC Server via a VNC Client you will need to use a client that is compatible with the RC4 DSM plug-in. Next you will need the key file from SmartPE. You can copy it off a machine that is booted to SmartPE by pressing Shift + F10 to open a command prompt, then changing directory to X:\Windows\System32, from there copy sdvncsvr.key. You will need to use this key with your VNC viewer. I would recommend using UltraVNC viewer. If you change the DSMPlugin to MSRC4, copy the sdvncsvr.key file to UltraVNC’s program files folder and rename it rc4.key you should be able to connect.

Hope that helps!

Erik

Link to comment
Share on other sites

  • 2 weeks later...
  • 1 year later...

Actually I have the same problem. I copied the key from the bootable disk. I installed UltraVNC with plugins for DSM and I am still not able to connect. Would you mind posting a step-by-step instructions how to get it done? I have followed your instructions above, but they didn't work for me.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...