Jump to content
DeployCentral

Active Directory Activation of Windows 10


nerdynerd
 Share

Recommended Posts

We are using Active Directory activation for Windows 10 and I'm running into an issue with my SmartDeploy images.  My images are built off of VL media and I do not modify the Windows key on the image prior to capture, so it's got the GLVK only on it.  I've captured the image in SmartDeploy without entering a key and have tried my answer file with and without the GLVK key and get the same result.  The issue is that I get the message below.  The systems appear to be properly activated by AD, and I think the message is due to the PCs having an OEM license that might be trying to activate, but I'm not sure. I've found that after imaging, if I manually change the product key to the GLVK, the error goes away.

Are there certain steps that must be taken in the SmartDeploy workflow to activate systems against AD that I'm possibly missing?

Activation issue.PNG

Link to comment
Share on other sites

SmartDeploy is essentially just passing through whatever key you provide (either in Capture Wizard or via an Answer File/in Deploy Wizard), and Windows is attempting to install that key (during Sysprep\Specialize) and then activate the endpoint. I haven't used this particular activation method myself, but from the docs, you seem to be on the correct track here using the GVLK to prepare these endpoints to be activated via AD. My best guess is that it's possible that Windows simply recognizes the GVLK and refuses to install it during the Specialize phase, which means that the endpoint would indeed have whatever OEM key may have been present on that endpoint prior to installation, which would not work with AD-based activation.

We could look at a deployment logset to confirm whether this is the case (there should be some evidence of the attempt and result in the detailed Sysprep Specialize log), but from your description, I believe you've potentially found a workaround already.

Try this: Deploy to an endpoint without specifying any product key.

Then log into the endpoint, open an admin command prompt, and run this command:

slmgr.vbs /ipk [enter the GVLK here, without any brackets]

You can run this command to confirm which key is currently installed (it will display a portion of the installed key):

slmgr.vbs /dlv

If the GVLK installed without error, you could attempt to run the activation command at this point as well:

slmgr.vbs /ato

However, I'm not sure what this command will do in an AD activation scenario, so you may want to hold off on that and just see whether the activation resolves itself within a day or so, as the endpoint communicates with your AD environment.

If you have any questions, feel free to reach out to support@smartdeploy.com.

Glenn
SmartDeploy Support

Link to comment
Share on other sites

One of the commands mentioned by SmartDeploy Support cleared out that error message, so I created an Application Package which I've outlined below. I'm not sure the error message was actually hurting anything since the system was activated by our AD activation service, but I thought it looked sloppy for it to say the previous activation had failed.

Application Pack:

Executable location: 

c:\windows\system32\cscript.exe

Arguments:

//B "C:\Windows\system32\slmgr.vbs" /ipk [GLVK key without brackets]

Full command:

"C:\Windows\System32\cscript.exe" //B "C:\Windows\system32\slmgr.vbs" /ipk [GLVK key without brackets]

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...