Jump to content

Newly captured images are showing up in SD as "unknown" with wrong file size

Recommended Posts

Anyone else run into this? Was literally working perfectly yesterday. I opened a ticket, but thought I'd ask here. The image captures with no errors - it's almost 14GB - in SmartDeploy it shows up as "Unknown" image with "0" images and the size is 303mb according to the display.

Very weird - what I've done: recaptured image 3 times, once to start, once after a reboot, once after recreating the capture ISO for my VM. I rebooted the deployment machine. I restarted the SmartDeploy service. I reinstalled SmartDeploy.

Same result in all cases.

Link to comment
Share on other sites

Found my own fix - replying here in case anyone else runs into it. Here seems to be the cause:

Captured an image - for this example, let's call it "my_win10image_03072019" - I delete this image in the console - I capture and image from the same machine - and call it the same name "my_win10image_03072019" - in the console, this now shows up as "UNKNOWN" image with a bizarrely small file size. If you look at the file, it's the correct size.

THE FIX: I right-clicked on the "unknown" image and selected "refresh" from the menu. It took 30-40 seconds or so, but it corrected and the image showed up with the correct name and the correct size.

I'm deploying it now, just to be sure that it is, indeed, a good image. But I found no documentation on this error - so I thought this might help someone. I opened a ticket, so maybe they can include some kind of error handling that looks beyond the name and maybe looks at the creation date and updates the screen/database if the image is newer than what is stuck in the display list.

Link to comment
Share on other sites

Well, that's the thing. Once I did the refresh - it was the same image. I don't know how you guys store the file names - if it's a database or a temp file or what - but it's like it saw the file name and kept the data from when it first started imaging.

So quick answer is - yes, the image worked, I already deployed it after doing the "refresh" - so this was strictly something with the way SmartDeploy decides how to present the info in the console.

To be fair to you guys - I am making LOTS of tweaks to my images and capturing them one after the other after each tweak. I think this was just a case of something stuck inside of however the files are displayed. I would've thought restarting the program would have cleared it up, but it didn't. I even restarted the machine itself. It wasn't until I right-clicked and hit refresh - and at that point the "unknown" disappeared and the correct name and file size replaced it.


Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...