Jump to content

"Please Specify an image file" Deployment Package


Recommended Posts

Hi, i need some guidance if possible.

I have been testing deployment packages to Laptops and Desktops to the SmartDeploy agent for unattended deployment.

The answer file attached to the package has been configured to point to the console host to pick up the image .WIM file in the C$/SmartDeploy/Images folder on the console host.

Yet, when i deploy the package to any machine, the machine boots into SmartDeploy and runs through unattended mode - and stops when specifying the image.

At this point, i am able to map and browse to where the file is, but it should be doing this automatically as per the answer files config. Yet this isn't working?


I have attached the .XML file - please can someone share some knowledge if anyone has experienced this and knows how to rectify the problem?




Link to comment
Share on other sites

Hi Jay,

This typically indicates a problem with your answer file, but in order to diagnose the problem, we'll need to see a logset from the same WindowsPE session where the error occurs. We've opened a support ticket, and we'll be in touch. 

SmartDeploy Support

Link to comment
Share on other sites

  • 1 month later...
  • 1 month later...

Not sure if this was resolved, but the problem that I was having with this was that the process of creating an Answer file and directing it to the network share by using SmartDeploy was adding a directory that the client could not connect to during the imaging process.

SmartDeploy created the path as \\Location\c$\location\... By removing the c$ and making it \\Location\Location\... the client was able to connect to the SmartDeploy server and process the image. Verify that the path that you set for your images and platform packs is reachable by the client that you are trying to image.

Link to comment
Share on other sites

Hi WixonStaff,

Thank you for sharing your experience! What you've described is definitely a good method for troubleshooting - by default, SmartDeploy will use the administrative share path (e.g. \\computername\c$\SmartDeploy) of whatever location you browse to in the Answer File Wizard, rather than the name of any network share that you may have manually created. And it's true that this may or may not be reachable from a target device depending on what set of credentials you use, your network environment, etc. If you're ever uncertain which path to use from a target device, you can always open a command prompt in WindowsPE (by clicking the link at the bottom of the SmartDeploy splash screen) and try mapping a network drive to the share manually:

net use * \\computername\SmartDeploy

net use * \\computername\c$\SmartDeploy

Once you've confirmed which path and credentials work most reliably from the target device, you can update your answer file to make sure that this is reflected, then recreate your media using the updated answer file, and you should be all set. 

Thanks again, and please feel free to reach out to support if we can assist you with anything. 

SmartDeploy Support


Link to comment
Share on other sites

  • 3 months later...

How do I remove the c$ to fix this? I am having this same issue. If I go to command prompt and run "net use * \\computername\SmartDeploy" it says Z drive is now connected. It will image unattended with no problem after that but how do I fix that in the answer file so I don't have to use the net use command every time? Below is the xml from my USB boot media.

<smartdeploy version="2.0" version_debug="2.0.3035.9811">
  <deploy_wizard mode="Unattended">
    <welcome skip="0">
    <select_image_source skip="0">
    <cloud_platform_authentication skip="0">
      <cloud_platform />
      <refresh_token />
    <select_cloud_image />
    <select_image skip="0">
      <image_file>\\ohco-ldp16-dt\SmartDeploy\Images\Windows 10 x64_GOLD.wim</image_file>
      <image_name>Windows 10 Core</image_name>
    <disk_options skip="0">
      <!-- 0 = Recreate drives, 1 = Wipe & load drives, 2 = SmartMigrate -->
    <product_key skip="0">
      <product_key />
    <end_user_license_agreement skip="1">
    <user_information skip="0">
      <full_name>Windows User</full_name>
      <organization_name />
    <regional_settings skip="0">
      <time_zone>(GMT-05:00) Eastern Time (US and Canada)</time_zone>
      <input_locale>English (United States)</input_locale>
    <display_settings skip="0">
      <resolution>Auto Detect</resolution>
      <color_depth>Auto Detect</color_depth>
      <refresh_rate>Auto Detect</refresh_rate>
    <network_tcpip_settings skip="0">
        <!-- 0 = Obtain an IP address automatically, 1 = Use the following IP address -->
        <ip_address />
        <subnet_mask />
        <default_gateway />
        <preferred_dns_server />
        <alternate_dns_server />
        <preferred_wins_server />
        <alternate_wins_server />
    <network_identification skip="0">
      <computer_name />
      <!-- 0 = Domain, 1 = Workgroup -->
      <workgroup />
    <join_domain_credentials skip="0">
      <server />
      <username />
      <domain />
      <password />
    <summary skip="0">
    <completion />
        <platform_pack skip="0">\\ohco-ldp16-dt\SmartDeploy\Platform Packs</platform_pack>
          <system_property enabled="1">DISABLE_SYSTEM_RESTORE</system_property>
          <system_property enabled="0">RESTORE_DRIVE_LETTERS</system_property>
          <system_property enabled="0">ENABLE_ADMINISTRATOR_ACCOUNT</system_property>
          <system_property enabled="1">PRESERVE_CRASH_CONTROL_SETTINGS</system_property>
          <system_property enabled="1">PRESERVE_DESKTOP_ICONS</system_property>
      <identification skip="0">
        <!-- 0 = Assign a new computer name automatically, 1 = Use the following naming method -->
        <naming_mode />
        <wmi_query>SELECT SMBIOSAssetTag FROM Win32_SystemEnclosure</wmi_query>
      <migration skip="0">
        <virtualization_platform />
        <files_to_exclude />
        <migrate_active_users />
        <migrate_active_users_days />
      <tasks />
      <client />
      <active_directory />
      <network_shares skip="0">
        <proxy_server_url />
        <username />
        <password />
      <session_id />
      <unattend_delay />



Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...