Jump to content

Moving SmartDeploy and reference machine data to new computer


Recommended Posts

Hi everyone,


I have SmartDeploy 2.0.3005 installed on a Windows 7 Pro 64-bit system. I have two reference images, two captured images and a few platform packs. I can edit my reference images with no problems in VMware player and then capture my changes with the SmartDeploy wizard to create a new image for deployment.


I would like to move everything to a new computer. The new computer has Windows 10 Enterprise 64-bit installed. I installed SmartDeploy successfully. Then I copied the content from the old computer’s SmartDeploy folders (images, reference machines and platform packs) to the new computer. After I copied the data, I imported the content from each folder within SmartDeploy successfully. To that point, all worked well. But when I try to capture an image with the wizard, I get the error message “Unable to mount the virtual volume”. After trying it about 10 times, I get the error “Device not ready” but then the virtual disk volumes are listed.


I also noticed after copying over the virtual reference machines, that VMware player gives me an error as well “Error while powering on: The operation was canceled by the user”. Strangely, when I keep trying to power it on (15 to 20 times), it will eventually power on.


Did anyone run into the same or similar problems?


Maybe the way how I moved everything over to the new computer was not the proper way, is there a “better” or “proper” way?


Thank you for your help!



Link to comment
Share on other sites

The new VM works fine, no problems.


I deleted the old VMs, copied them over again to a new folder, then imported them into SmartDeploy. This time I did not try to open the VMs in VMware Player, I immediately tried to capture an image. This time I only received the message "Device not ready", but SmartDeploy was able to see the virtual disk volumes.


Then I tried to open the VMs in WMware Player. Same issue as before, it says “Error while powering on: The operation was canceled by the user”. After I tried to power on the VM a few more times I got this error:

The operation was cancelled by the user

Cannot open the disk 'C:\SmartDeploy\Reference Machines\Windows 10 x64\Windows 10 x64.vmdk' or one of the snapshot disks it depends on.

Module 'Disk' power on failed.

Failed to start the virtual machine.


Any suggestions or ideas?

Thank you!

Link to comment
Share on other sites

I found a ".lck" file in the VMware folder of the VM. After deleting that, the VM runs without any problem.

The only problem that is left now is SmartDeploy telling me "Device not ready" when I try to capture a new image of the VM. When I proceed I get this error:


CaptureVirtualDisks.Mount returned: 21. The device is not ready.


Any ideas what I can do to fix this error?

Thank you!

Link to comment
Share on other sites

If you're able to delete the lck file and boot the VM, then you should be able to do a warm capture. But deleting those files is normally something you don't want to do, as it may interfere with VMwares processes. You may consider just re-making the VMs in lieu of troubleshooting this for too long. 

Link to comment
Share on other sites

I think I may have found out what was causing all the problems that I described above.


After building a brand new VM on the new computer, I had the exact same problems with the new VM that I had with the other VM that I copied over from the old computer. After brainstorming with my supervisor we decided to copy the new VM to the old computer and try it there. No problems. Only difference, the version of SmartDeploy that is installed on both computers:


New computer: 2.0.3010

Old computer: 2.0.3005


I hope this will help other who run into the same or similar issue.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...