Jump to content

Dell Latitude 5590 - Boot device missing after deployment


Recommended Posts


I've just been through the following troubleshoot, and was wondering if someone else have had the same issue. In that case I'll share my experience and solution:

We just bought some 30 E5590 laptops to roll out a workstation upgrade for our users.

The image deployment goes well until the mandatory BIOS upgrade from the platform pack kicks in. The laptops come with 1.0.8 out of the box, and is upgraded to 1.1.9 during the deployment.

Right after this upgrade the PC reboots, and I was met with a "No boot device found" screen.

In the BIOS the UEFI boot manager is missing from the boot sequence. When I added it manually, and pointed to the specific EFI boot manager from the deployed OS, I was now facing a corrupt OS message (couldn't be repaired with Win10 from a USB).

I also noticed the SSD was present in the legacy devices of the boot sequence before the BIOS upgrade, but was now missing from the list after the upgrade.

What I tried:

Switch from legacy to UEFI boot (and vice versa).

Upgraded BIOS to 1.2.3, and downgraded to 1.0.8.

Changed drive settings from RAID to AHCI and redeploy the image.


In the end it turned out I had to activate the UEFI PXE settings on the NIC in BIOS, and redeploy the image once more. Worked like a charm right after.

As I have not seen this specific issue mentioned in any of the SmartDeploy documentation I thought it could be worth sharing with the community.

Link to comment
Share on other sites

Yes, by default these new machines ship with SecureBoot on, UEFI only.  But, the PXE boot settings don't have the UEFI network stack enabled by default.

So, when you PXE boot out of the box it is a Legacy/BIOS boot option and that won't work.  The way the machine is configured and the boot option have to match.

If you want to PXE boot these machines, have to enable the UEFI network stack first.

If USB boot, then you simply select the UEFI USB boot option.

Link to comment
Share on other sites

  • 1 year later...

It's the same for all new Dell's really.  The machine needs to be in it's default settings.  UEFI only, Legacy disabled, SecureBoot On.

Then on the F12 screen you need to ensure you make a UEFI boot selection, and not a Legacy selection.

Once booted to SmartDeploy the lower right-hand corner has to say UEFI and not BIOS.


Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...