Jump to content

Issues with PXE on Dell Latitude 3050 using UEFI

Recommended Posts



I just recently deployed 60 Dell Latitude 3050's with my technicians.  We had some issues when leaving the computers set in UEFI mode.  The PXE starts but hangs and moves really really slow loading the boot file.  I left several booting went to lunch and came back and still didn't boot into smartdeploy boot file.


After some word eating on my part, as my technicians recommend legacy mode instead, i insisted it wasn't necessary.  But low and behold that worked flawlessly, after disabling secure boot and disabling UEFI boot options, legacy PXE worked fine.


I did some quick research and I think it could be a driver issue with the PXE in winpe mode, some other people reporting having issues with WDS, but didn't really find any solution.


So just fyi, as we have discovered, from model to model, UEFI seems to not work, and on some legacy doesn't work.

I don't believe this anything to do with smartdeploy, but more WDS itself and manufacture drivers, not sure if anyone else has these issues as well.

Perhaps experimenting with changing the driver in WINPE of the platform pack.  I realize it could also be something simple as a bios update.


Link to comment
Share on other sites

The Windows PE driver doesn't get used until Windows PE is fully booted.  With PXE boot this would either be down to the version of Windows Server that is being used, or the BIOS/firmware on the machine.  Looks like a few revisions of back in the BIOS they updated the Realtek NIC firmware, so something like that could make a difference.

Link to comment
Share on other sites

  • 1 month later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...