Jump to content

BSOD When Deploying Windows 7 on an HP EliteBook 1040 G3


Recommended Posts


I have 3  HP EliteBook 1040 G3 laptops that I have tried to image with Windows 7. Every time I tried to image one it would appear to image the computer normally but on the first boot up after imaging the system it will bluescreen when you see the Windows logo come up on the screen. The BSOD error code is 0x0000007B which has been the same error after every try.

I have tried a number of things including:

  • Building new boot media
  • Updating Platform packs (as well as deleting the platform pack and re-downloading it)
  • Image with different image files
  • Updating the BIOS on the laptop
  • Rolling back the Laptop BIOS to an earlier version

I will also not that these Laptops have SSDs and were able to image and boot fine with a Windows 10 image. I have also tried installing the KB2990941 Hotfix on the Windows 7 reference machine and creating a new image but it ends up with the same error.

The systems can install Windows 7 from a disc without problem but I have not yet been successful with imaging.

Please advise on what I should try next.

Link to comment
Share on other sites

  • 6 months later...

I'd like to resurrect this topic, as I'm experiencing the same issue as the OP, and took the same steps in attempt to correct it.  This issue is being experienced on an HP ProBook 450 G2, using the Platform Pack for Windows 7x64.

The image deploys fine on a Dell 7010 [with the appropriate PlatformPack].

Hot fixes and SmartDeploy storage patch for Windows 7 applied.


Link to comment
Share on other sites

I am in the same situation too. HP Z2 Mini G3 (6th Gen CPU) BSOD with same code. Win 7 x64 Pro Platform Pac. Image had deployed fine on HP Elitedesks, Z200, 8200, 8300, Laptops...etc.

I hope is has nothing to do with these having M.2 SSD media and not a physical drive?

Anyway , multiple attempts and I have a dead box. No way to recover since deployment wipes the recovery partition. 

Going to continue to work on this, but will be watching this thread too.

Link to comment
Share on other sites

I managed to get this working.

I downloaded/install newest smartdeploy version 2.0.3005. I then followed the manual installation of the NVMe driver pack on the reference VM (Win7x64) (link to forum post: )



Captured the machine, created new deploy media, returned the Target >> HP Z2<< to BIOS Default (UEFi Enabled) and booted with SD Image. Reboot found the M.2 drive (unlike before) and booted correctly.

I am now Golden.


Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...