Jump to content
DeployCentral

How to change the default directory


lphooper03
 Share

Recommended Posts

Can I please get instructions on how to change the default SmartDeploy Directory within the settings menu. I see that it is a drop down, which tells me that I should be able to modify a config file to specify another location.

My reason for this is that I have all of my platform packs, answer files, and images on a network shared server that I have mapped to the SmartDeploy host computer (drive letter H:). I've tried modifying the config file at: C:\Program Files (x86)\SmartDeploy\SmartDeploy Enterprise\Resources\Configuration\SmartDeploy.config

I've tried a UNC path as well as the mapped drive letter, which happens to be: H:\Smartdeploy

Once modifying the config file I restart the console service, as well as the program, and I go back into the settings menu and the default location changes to a blank default dropdown with a secondary option to choose the C:\Smartdeploy. How do I get the H:\Smartdeploy to show up in this list. 

Link to comment
Share on other sites

  • 3 weeks later...
  • 3 weeks later...

I spoke with SmartDeploy Support. I have been informed that if one edits the configuration file, this might be doable in theory, although this has not been heavily tested by SmartDeploy to date, and I have had no luck with it to date running SmartDeploy Enterprise v2.0.2000.5742 in Windows 10 Enterprise.

  1. Close SmartDeploy if it is running, then open C:\Program Files (x86)\SmartDeploy\SmartDeploy Enterprise\Resources\Configuration\SmartDeploy.config in a text editor.
  2. Edit <SmartDeployDirectory>C:\SmartDeploy</SmartDeployDirectory>, replacing C:\SmartDeploy with the path of the permanently mapped network drive in which your SmartDeploy data will be stored.

I have not had any success with this, even when stopping the SmartDeploy Enterprise Console Service, making a copy of the file, editing the file, copying it back as an administrator, successfully overwriting the existing file, then restarting the SmartDeploy Enterprise Console Service. It keeps reverting to the default location.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...