Jump to content
DeployCentral

Smartdeploy doesnt set country settings.


barhbarh
 Share

Recommended Posts

When i deploy a image with smartdeploy om a pc (with a usb-stick) and country/region are set to Dutch, the settings on the target pc after deploying the image are in the engish state.

Here a quick discription how i make a image. <smartdeploy version="1.1" version_debug="1.1.1980">

- I install windows in vmware, at the setup i set country/region settings to Dutch. (and do a full install of xp machine)

- I capture the vmware machine (standard image)

- I use media wizard to make a USB-stick i can deploy the image with (offline deployment media)

- Then i deploy the image with the USB-stick without a anser file, and select "Dutch (Netherlands)" at the "Language country/region" settings

- i export the answer file, (i can see in the summary, that "input locale:" is set to "Dutch (Netherlands)".

- here the part of the settings of the answer file,

"

</user_information>

<regional_settings skip="0">

<time_zone>(GMT+01:00) Amsterdam, Berlin, Bern, Rome, Stockholm, Vienna</time_zone>

<input_locale>Dutch (Netherlands)</input_locale>

</regional_settings>

"

- After the deployment, i see that the target pc has the english setting

More info:

- when i look at the reg keys in the vmware machine, the country settings are in the Duch state at:

"HKEY_CURRENT_USER\Control Panel\International"

"HKEY_USERS\.DEFAULT\Control Panel\International"

- After deployemnt the reg keys are in the English state

- I still got a old Smartdeploy USB-stick i made with <smartdeploy version="1.1" version_debug="1.1.1910"> , i copied the wim file to this stick and deployed the wim file with this version, here the taget pc keeps/sets the Dutch country/region settings. (?)

Thanks in advice for the help

Link to comment
Share on other sites

Hello,

It looks like the language isn't picking up correctly with the unattended answer file. I imagine if you try this without the answer file it will work. As a work around you can follow the informaotin in this blog post to set the custom regional settings. You will want to set all four options to 0413 and your answer file should look like the example below. Once you have edited the answer file it should work in unattended mode and correctly set the regional settings. I will look into what is causing the default setting to be ignored during the unattended deployment.

                &lt;regional_settings&gt;
                        &lt;time_zone&gt;(GMT-08:00) Pacific Time (US and Canada)&lt;/time_zone&gt;
                        &lt;input_locale&gt;
                                &lt;ui_language&gt;0413&lt;/ui_language&gt;
                                &lt;system_locale&gt;0413&lt;/system_locale&gt;
                                &lt;user_locale&gt;0413&lt;/user_locale&gt;
                                &lt;input_locale&gt;0413&lt;/input_locale&gt;
                        &lt;/input_locale&gt;
                &lt;/regional_settings&gt;

Thanks,

Erik

Link to comment
Share on other sites

  • 2 months later...

Will this also work for Windows XP?

Hello,

It looks like the language isn't picking up correctly with the unattended answer file. I imagine if you try this without the answer file it will work. As a work around you can follow the informaotin in this blog post to set the custom regional settings. You will want to set all four options to 0413 and your answer file should look like the example below. Once you have edited the answer file it should work in unattended mode and correctly set the regional settings. I will look into what is causing the default setting to be ignored during the unattended deployment.

                &lt;regional_settings&gt;
                        &lt;time_zone&gt;(GMT-08:00) Pacific Time (US and Canada)&lt;/time_zone&gt;
                        &lt;input_locale&gt;
                                &lt;ui_language&gt;0413&lt;/ui_language&gt;
                                &lt;system_locale&gt;0413&lt;/system_locale&gt;
                                &lt;user_locale&gt;0413&lt;/user_locale&gt;
                                &lt;input_locale&gt;0413&lt;/input_locale&gt;
                        &lt;/input_locale&gt;
                &lt;/regional_settings&gt;

Thanks,

Erik

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...