Jump to content

Unable to Install SD Client on PC


Recommended Posts

I just installed v. 3.0.1005 SmartDeploy - that went fine.

Opened brand new just out of the box HP PC. (EliteDesk 800 G6 - Mini PC).  Running Windows 10 20H2.

Attempted to install client, but every attempt to do so I get this error during installation when attempting to start the SDClientService:

"Error 1920. Service SmartDeploy Client Service (SDClientService) failed to start. Verify that you have sufficient privileges to start system services."  Only option is to Retry or Cancel.  Retry gives the same error message and Cancel rolls back the entire installation.

I am running the install as an administrator on the machine.  (Tried both domain admin and local admin accounts.)

Troubleshooting Steps:

1.  Tried to install after both after joining the domain and disjoining domain.
2.  Ran msconfig to do clean boot - only Microsoft Services were allowed to run and killed all Start Up processes in Task Manager.
3.  Tried both x64 and x32 versions of the client install.
4.  Copied Installation files directly to local hard drive for install.
4.  Tried installing on my main computer and it failed the same way (computer is about 4 years old with a lot of stuff on it, but just wanted to see if it would work).

Not sure what else to do.  I ran the install with logging so I have the log file if a SmartDeploy tech wants to look at it. 

Error attached.


Link to comment
Share on other sites

When you need to image systems that are coming straight out the box. you should always go straight to USB media. It's much more effort to power them on, complete the Windows OOBE, and then install the SmartDeploy Client to get it into the console and then push the deployment. 

HP and Dell OEM software are often a problem, using a port or causing an issue some other way. It can help to uninstall that stuff like 'JumpStart' or 'Support Bridge' (Sorry I'm going off memory here.) 

If you uninstall that OEM software and still can't install the client, please reach out to support so was can look at logs and connect to the machine to identify the blocking application/service. 

Link to comment
Share on other sites

Thank you, Jeff...you make great points there!

I learned in the past that JumpStart will interfere, so I always disabled that service first.  These latest HP machines don't have JumpStart anymore.  I did disable all of the running HP services, but I will try uninstalling the software and trying again.

Link to comment
Share on other sites

The resolution was to use the Tools Tab in the SmartDeploy console and click "Generate Client Installer".  This is a new requirement in Version 3.  WOuld have been helpful information to have.

Using this generated installation file, it installed successfully.

Link to comment
Share on other sites

  • 1 year later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...