Jump to content
DeployCentral

SmartDeploy service is set to "automatic" after imaging


Recommended Posts

As the title suggests, when I finish imaging a client PC, the SmartDeploy service is set to automatic - therefore it gets stuck "starting" and the client doesn't register with the Smartdeploy console.

So, now I'm just in the habit of going into the services after I finish imaging a PC and setting the SmartDeploy service (not the SmartDeploy Enterprise Client) to manual. However, when the time comes to remotely image my machines, I can see this as being a huge pain.

I'm on 2.0.3085, but this has been going on for awhile, at least several versions. Since the system installs the services AFTER the imaging, I would think it would get set correctly.

Any ideas?

Thanks --Ted

Link to comment
Share on other sites

Following a deployment, the SmartDeploy service should be disabled. This service is used to do a few functions post deployment only, and should disable itself. The SmartDeploy Enterprise Client is a separate service that should be set to Automatic (Delayed) - but will only be there if the client installation was enabled in the Answer File. 

I've never seen any instances where one affected the other, but if you contact support we can take a look at your image for you and investigate.

Link to comment
Share on other sites

OK - good to know - after imaging - it's set to Automatic, consistently. This is across 4 different images, deployed to 4 different types of machines (desktops, laptops and workstations.) So this is not isolated to one image. I've been setting it to manual to get the PC to talk to the console - I'll change it to Disabled.

I'm not sure I understand how this is an issue with the image itself. Is the SmartDeploy services installed from the image?

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...