Jump to content
DeployCentral

Assign static drive letter for USB


dewin
 Share

Recommended Posts

Hello,

I'm deploying a .wim image to workstation pc's and i'm using a unattended file (see below) from a USB key.

The <image_file> is pointing to the usb drive, this can vary. Is there a possibility to assign a static drive

letter for the usb key?

Thanks for the reply.

Kind regards

Dewin

<?xml version="1.0" encoding="utf-8"?>

<smartdeploy version="1.1" version_debug="1.1.1910">

<deploy_wizard>

<welcome>

<hide_options_button>false</hide_options_button>

</welcome>

<select_image>

<image_file>E:\z\XP.wim</image_file>

<image_name>Windows XP SP3</image_name>

</select_image>

<disk_options>

<!-- 0 = Recreate drives, 1 = Wipe & load drives, 2 = SmartMigrate -->

<disk_option>1</disk_option>

</disk_options>

<product_key>

<product_key/>

</product_key>

<end_user_license_agreement>

<accept_eula>false</accept_eula>

</end_user_license_agreement>

<user_information>

<full_name>Company</full_name>

<organization_name>Company</organization_name>

</user_information>

<regional_settings>

<time_zone>(GMT+01:00) Amsterdam, Berlin, Bern, Rome, Stockholm, Vienna</time_zone>

<input_locale>Dutch (Netherlands)</input_locale>

</regional_settings>

<display_settings>

<resolution>Auto Detect</resolution>

<color_depth>Auto Detect</color_depth>

<refresh_rate>Auto Detect</refresh_rate>

</display_settings>

<network_tcpip_settings>

<ipv4>

<!-- 0 = Obtain an IP address automatically, 1 = Use the following IP address -->

<static>0</static>

<ip_address/>

<subnet_mask/>

<default_gateway/>

<preferred_dns_server/>

<alternate_dns_server/>

<preferred_wins_server/>

<alternate_wins_server/>

</ipv4>

</network_tcpip_settings>

<network_identification>

<computer_name/>

<!-- 0 = Domain, 1 = Workgroup -->

<membership>1</membership>

<domain/>

<organizational_unit/>

<workgroup>WORKGROUP</workgroup>

</network_identification>

<join_domain_credentials>

<username/>

<domain/>

<password/>

</join_domain_credentials>

<wds_credentials>

<server/>

<username/>

<domain/>

<password/>

</wds_credentials>

<summary>

<hide_export_button>false</hide_export_button>

</summary>

<completion/>

<advanced_options>

<general>

<platform_pack>[imageFolder]\Default.ppk</platform_pack>

<system_properties/>

</general>

<identification>

<!-- 0 = Use the existing computer name, 1 = Use the following naming method -->

<naming_mode>0</naming_mode>

<naming_methods/>

<custom_naming_scheme/>

<prefix/>

<wmi_query/>

</identification>

<migration>

<protected_folder>Backup</protected_folder>

<virtualization_platform>VMware Workstation 6</virtualization_platform>

<create_desktop_shortcut>true</create_desktop_shortcut>

<files_to_exclude><exclude>$ntfs.log</exclude><exclude>$Recycle.Bin\*</exclude><exclude>[systemRoot]\CSC</exclude><exclude>[systemRoot]\Temp\*</exclude><exclude>hiberfil.sys</exclude><exclude>pagefile.sys</exclude><exclude>RECYCLER</exclude><exclude>System Volume Information</exclude></files_to_exclude>

</migration>

<tasks><task><phase>PREIMAGE</phase><command>E:\z\Part.vbs</command></task></tasks>

</advanced_options>

<settings>

<active_directory/>

<network_shares/>

<proxy_server>

<proxy_server_url/>

<username/>

<password/>

</proxy_server>

<session_id/>

<unattend_delay/>

</settings>

</deploy_wizard>

</smartdeploy>

Link to comment
Share on other sites

Hello Dewin,

You cannot assign a specific drive letter to the USB drive. It will vary with every machine that is booted due to different drive configurations. The easiest thing would be to use the %SmartDeploy_Media% environment variable to address the USB drive. This variable is assigned the drive letter in which SmartPE was booted from. You can then change the image and task path to %SmartDeploy_Media%\z\XP.wim and %SmartDeploy_Media%\z\Part.vbs.

Hope this helps,

Erik

Link to comment
Share on other sites

Hello Erik,

Thank your for your reply. When i change the unattended file i get the message "Please specify an image file" when i manualy point SmartDeploy to the image %SmartDeploy_Media%\z\xp.wim i get the message that it is not a image file. But when i point him to E:\z\xp.wim the deployment continues.

Any suggestions :)

Thanks

Dewin

Hello Dewin,

You cannot assign a specific drive letter to the USB drive. It will vary with every machine that is booted due to different drive configurations. The easiest thing would be to use the %SmartDeploy_Media% environment variable to address the USB drive. This variable is assigned the drive letter in which SmartPE was booted from. You can then change the image and task path to %SmartDeploy_Media%\z\XP.wim and %SmartDeploy_Media%\z\Part.vbs.

Hope this helps,

Erik

Link to comment
Share on other sites

Hi Dewin

Try using [AnswerFolder]\z\xp.wim this is what Media Wizard will automatically update the path to when specifying an answer file during the creation of boot media. This assumes that the SmartDeploy.xml is on the root of the USB drive. You will still want to use %SmartDeploy_Media% to specify the VBS task.

Thanks,

Erik

Link to comment
Share on other sites

Thanks it works ! :)

Kind regards

dewin

Hi Dewin

Try using [AnswerFolder]\z\xp.wim this is what Media Wizard will automatically update the path to when specifying an answer file during the creation of boot media. This assumes that the SmartDeploy.xml is on the root of the USB drive. You will still want to use %SmartDeploy_Media% to specify the VBS task.

Thanks,

Erik

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...