Jump to content

Application Deployment


Recommended Posts

There are a bunch of topics on this subject, but nothing seemed to answer my questions.

Firstly - where are logs for application deployments? I can't find them in the C:\windows\temp folder on either the target or source. Event view logs aren't helpful as I can see the smartdeploy client service and all it says it started successfully.

Right now I'm just trying to get Chrome to install with the downloaded application pack. I can see the source is connected to the target on 8733, so its not ports. I can see that the application packs get copied to the C:\windows\sysWOW64\smartdeploy\sources folder, but no C:\windows\TEMP\smartdeploy folder seems to get created and the application doesn't install.

I do see a yellow ! next to the computer in the console and when I look at the status I see application deployment error. Click on Logs... nothing helpful and a newly created but empty CSV with the same name as the computer.


Any help? I'd really love to be able to build these applications into the deployment process but can't get any of them to work.



Link to comment
Share on other sites

When deploying applications with App Packs, the best place to look for troubleshooting is the Application log on the target machine. 

That's a good sign that the pack is being copied to the \Windows\sysWOW64\SmartDeploy\Sources\ folder. Since 2.0.3050, the location of extraction is now C:\Windows\Temp\!sdspk\Application Manager\appname\Files. 

Are other Application Packs installing successfully?

Link to comment
Share on other sites

at the moment I can't get any application packs to install. Looks like the C:\windows\temp\!sdspk folder doesn't exist either.

some more info: this is a clean windows 10 machine with only a local admin account. Not joined to the domain or getting any policies that might prevent it. No AV installed or security apps installed either.

Link to comment
Share on other sites

  • 2 weeks later...

I am having this same problem " I can't get any application packs to install. Looks like the C:\windows\temp\!sdspk folder doesn't exist either.". Has there been a resolution? I am starting with just trying the Fire Fox pack before I go creating my own pack, and even the smart deploy ready Fire Fox pack will not deploy. we are pushing to a win10 machine that was imaged with smart deploy. 

My gut is telling me this may be a permissions issue since our win10 newly imaged machine is not on the domain and I'm not sure what rights are being used by the smart deploy console when pushing the pack to the agent for installation.

Please advise.




I tried pushing Firefox twice approximately 30 min apart. I just tried again and this time it ran! totally  confusing as i did nothing to rectify the situation and i just deployed the application pack the same way as I did the first 2 times. I have no virus protection on the newly imaged win10 machine i'm pushing the applications to but I do have trend installed on the smart deploy console. Is that a potential issue? 


Edited by BPF12207
Update to Original Condition
Link to comment
Share on other sites

  • 2 months later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...