Jump to content

Can't install an MSI using "applications packs"

Recommended Posts

ok, I've tried every permutation I can think of - what's the trick to running an MSI in an application pack. EXEs, I have no trouble with - MSIs just fail with no explanation.


Attached is the run command - I've tried with a mapped drive and by putting in the full location (e.g. \\servername\folder\msifile.msi)


Any help would be appreciated.



Link to comment
Share on other sites

In the Application Manager window you have in your screenshot, right-click the Files node on the left, and click Add File to add your MSI file. Then, to the right of the executable location click Select, and select the msi file. This should automatically change your executable location in that field. Then edit it so that it looks like this;

msiexec.exe /i "[ApplicationsFolder]\Zoom Video Conferencing\Files\ZoomInstallerFull.msi"

You can leave your arguments as-in in the arguments field, and then you should see a successful deployment of the application. 

Link to comment
Share on other sites

The first thing you should do if you haven't, is test an Application Package available for download from the console. This will make sure that the service is working as intended, then you can dig into why your custom pack isn't working. 

The next step is to try your App Pack deployment, watching the C:\Windows\Temp\SmartDeploy\Scratch folder on the target. Your App Pack contents will be extracted here. (It's removed after the install, or after a failure.) If you see the folder appear here, then you know your app pack  is being copied and extracted successfully. 

This means that there's a problem with your syntax, or something else is blocking the installation. At this point, you can contact Support and send in your App Pack for us to test and we can see if it's related to your target, or the App Pack itself. 


Link to comment
Share on other sites

Alright - so as part of my troubleshooting, I uninstalled the smartdeploy client from the machine I was using to test the app deployment - deleted it from "Computer Management" and then reinstalled the smartdeploy client. Now it doesn't show up at all in Computer Management. Both services are running on the Client PC. I can ping in both directions. Any ideas?

Link to comment
Share on other sites

  • 3 weeks later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...