Jump to content

Platform Packs Stuck Downloading

Recommended Posts

Hello, I'm having some trouble downloading platforms packs. I am trying to download a platform packs for an HP Elitebook 850 G3 and an HP Elitebook 850 G5. I can find them in the list of available platform packs and tell it to download but it just sits at 0% even when I let it run overnight. I tried to download a completely different platform pack in case it was just something with that series but that one also has the same problem.

I have not downloaded any platform packs since the Windows updates were installed earlier this month and I am using Smartdeploy version 2.0.3005.8566. The OS is Windows Server 2012 R2 which I have tried rebooting as well but that did not resolve the issue. I'm not sure if anyone else has had this same problem.

This is what I see when i go to the platform pack library:


Any help is greatly appreciated.

Link to comment
Share on other sites

One other user was stuck in this state, and we were able to get it going by re-registering some DLLs. Can you Open a command prompt and try the following commands? After that, please restart your system, remove the erroneous packs and try the download again. 

regsvr32 "C:\Program Files (x86)\SmartDeploy\SmartDeploy Enterprise\Resources\SmartCOM.dll"

regsvr32 "C:\Program Files (x86)\SmartDeploy\SmartDeploy Enterprise\SDK\Bin\64bit\SmartCOM.dll”

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...